更新flutter出现的问题

更新flutter出现的问题 · May 21, 2019 clicks

手贱把Flutter升级到最新版本,然后怎么安装都失败

执行 flutter precache 或者 flutter doctor 的时候,总是报错或者停留在

Downloading android-arm64-release/linux-x64 tools

检查了本地环境变量设置

FLUTTER_STORAGE_BASE_URL: https://storage.flutter-io.cn
PUB_HOSTED_URL: https://pub.flutter-io.cn

没有问题,完全按照官方的来,但是就是没用。推测是:官方的中国镜像有问题

后来索性打开 flutter-io.cn 网站,页面最下面还有个上海交大的镜像。然后换成交大的镜像,一切顺利


FLUTTER_STORAGE_BASE_URL: https://mirrors.sjtug.sjtu.edu.cn
PUB_HOSTED_URL: https://dart-pub.mirrors.sjtug.sjtu.edu.cn